What settings do I need to apply to use the Line In port on a v2 Warp as the source for Music On Hold.
I tried to re-use the steps in http://pikawarp.org/?p=51 for the v1 Warp, but that doesn't seem to work. I just get silence.

I've then tried guides for FreePBX so set up a new Streaming Category in Music On Hold:
Category Name: pika-linein
Application: /usr/sbin/ast-playlinein
Optional Format: ulaw

/usr/sbin/ast-playlinein root:root rwxr-xr-x

#!/bin/bash
/usr/bin/arecord -q -c 1 -r 8000 -B=2048 -f S16_LE

Default inbound route has pika-linein as the Music On Hold (setting to default plays the supplied files)

At best I get a single dull beep, and then silence.

I've tried stopping asterisk to check with arecord at I get:
root@openwarp:/usr/sbin# arecord -vv -V mono
Recording WAVE 'stdin' : Unsigned 8 bit, Rate 8000 Hz, Mono
Plug PCM: Mu-Law conversion PCM (MU_LAW)
Its setup is:
stream : CAPTURE
access : RW_INTERLEAVED
format : U8
subformat : STD
channels : 1
rate : 8000
exact rate : 8000 (8000/1)
msbits : 8
buffer_size : 4000
period_size : 1000
period_time : 125000
tstamp_mode : NONE
period_step : 1
avail_min : 1000
period_event : 0
start_threshold : 1
stop_threshold : 4000
silence_threshold: 0
silence_size : 0
boundary : 2097152000
Slave: Hardware PCM card 0 'alsawarp' device 0 subdevice 0
Its setup is:
stream : CAPTURE
access : MMAP_INTERLEAVED
format : MU_LAW
subformat : STD
channels : 1
rate : 8000
exact rate : 8000 (8000/1)
msbits : 8
buffer_size : 4000
period_size : 1000
period_time : 125000
tstamp_mode : NONE
period_step : 1
avail_min : 1000
period_event : 0
start_threshold : 1
stop_threshold : 4000
silence_threshold: 0
silence_size : 0
boundary : 2097152000
appl_ptr : 0
hw_ptr : 0
#+ | 00%

The vu meter never registers any audio. I've checked the source is playing, and changing the volume, but still never see anything.

Have I missed something?