Results 1 to 4 of 4

Thread: Backup WARP SDCARD using a MAC

  1. #1
    Dforster Guest

    Default Backup WARP SDCARD using a MAC

    Dear all,

    I would like to backup both my Pika 2 units SDCARD's using a MAC - does anyone have the correct MAC terminal commands to help me do this? I want to backup and duplicate the card in each unit least I have problems further down the line (I have also bought some go-fast Samsung x10 - 16gb SDCARDS I would like to try instead of the 16GB SDCARD I am using now (perhaps a speed increase in the unit?).

    Any help is much appreciated.



  2. #2
    Dforster Guest


    UPDATE - On Goggling' for a bit, I discovered these tools, PiFiller, PiCopier and PiWriter, which when run on the MAC enable it to make perfect copies of the Raspberry Pi BOOT SDCARD - based on a Ext4 format too - would these maybe do the job? Cheers for any feedback... Dan

  3. #3
    Join Date
    Jul 2008


    Hi Dan,

    The Pi* tools have a chance of working.

    Otherwise, have you tried the commands below?

    Insert the SD master and obtain the image:
    1 - cd /media/xxxxx
    2 - tar -zcvpf /root/ImageName.tar.gz *

    Insert the new SD card and commit the image:
    3 - unmount /media/yyyyy
    4 - mkfs.ext4 /dev/sdb1
    5 - tune2fs -i 0 /dev/sdb1 -L WARP-SD
    6 - mount the SD card
    7 - cd /media/WARP-SD
    8 - touch .WARP-SD
    9 - tar -xcvf /root/ImageName.tar.gz

  4. #4
    Dforster Guest



    Update so far...

    1. I put the SDCARD in the Mac, it didnt see it and asked if I wanted to 'Initialize' it... So I said No... and there's me thinking they did everything ;-)

    I then called a friend and he said he has a stand alone SDCARD Nibble copier, so I am going to try this. If it works, they are about 80 on ebay (from the far east).

    I even tried to add a LINUX VMWARE Fusion machine, which all works properly, but it wont see the SDCARD unless the MAC does...

    I reckon I need to put together something from an old mini PC and run LINUX properly... You would think it maybe possible to mount the USB stick (with an SDCARD adaptor in it (card attached)) - an issue a command to do it using ssh? In the unit itself...

    One more quick question, I seemed to have lost my console/dsp. ability on both my Pika 2's, has an update maybe messed this up - is there a way to tell (using SSH, etc.)?

    Cheers again for all your help.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts