Results 1 to 6 of 6

Thread: Make error in PADS

  1. #1
    lanformation Guest

    Default Make error in PADS

    Whe attempting to run make the follow error appears:

    Applying chan_pika.patch using plaintext:
    patching file Makefile.am
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored -- saving rejects to file Makefile.am.rej
    patching file configure.ac
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored -- saving rejects to file configure.ac.rej
    Patch failed! Please fix chan_pika.patch!
    make: *** [/PADS_1.1.0.62/build_warp/chan_pika-tags-3.4.0.126/.configured] Error 1

  2. #2
    Join Date
    Jul 2008
    Posts
    268

    Default

    Yes, I believe this is a bug in PADS. The easiest way to work around this is to delete the offending 'chan_pika' folder in '<your PADS checkout folder>/build_warp' and rebuild.

  3. #3
    lanformation Guest

    Default Tried that

    I followed your suggestion to remove the chan_pika directory from the build_warp, and again ran make, got the same error. Went to the package directory and removed the chan_pika from there, ran make and the complie completed without error, ran make image which also completed OK, copied cuImage.warp to the TFTPBOOT directory. Ran the correct SETENV commands and saved the ENV values, upon reboot the PIKA attempted boot and received a BAD MAGIC NUMBER error after 3/4 boot?

  4. #4
    agauthier Guest

    Default

    What is the full log error that you get?
    Is it something like:
    ## Loading RAMDisk Image at 02200000 ...
    Image Name: PIKA Warp 1.0.0-222
    Image Type: PowerPC Linux RAMDisk Image (gzip compressed)
    Data Size: 44368879 Bytes = 42.3 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... Bad Data CRC


    If so you should try to set the max image size uncompression to something bigger.

    This is explained in troubleshooting
    under
    Run from Flash

  5. #5
    lanformation Guest

    Default Posted

    ~~ Protected Environment Variables: ~~
    ethaddr=00:1E:84:00:01:39
    serial#=PIK-258- 00709
    => setenv rootpath /usr/src/PADS_1.1.0.62/build_warp/root
    => saveenv
    Saving Environment to Flash...
    Un-Protected 2 sectors
    Un-Protected 2 sectors
    Erasing Flash...
    .. done
    Erased 2 sectors
    Writing to Flash... done
    Protected 2 sectors
    Protected 2 sectors
    => printenv
    ethact=ppc_4xx_eth0
    filesize=3C886
    fileaddr=100000
    postdelay=1
    bootdelay=3
    baudrate=115200
    loads_echo=1
    preboot=echo
    netdev=eth0
    hostname=warp
    post_dma_lb_loops=10
    nfsargs=setenv bootargs root=/dev/nfs rw nfsroot=${serverip}:${rootpath}
    ramargs=setenv bootargs root=/dev/ram rw ramdisk_size=130000
    addip=setenv bootargs ${bootargs} ip=${ipaddr}:${serverip}:${gatewayip}:${netma1
    addtty=setenv bootargs ${bootargs} console=ttyS0,${baudrate}
    bootfile=cuImage.warp
    net_nfs=tftp 200000 ${bootfile};run nfsargs addip addtty;bootm
    nand_flash_nfs=load_nand_kernel;run nfsargs addip addtty;bootm
    load_nand_kernel=nand read.jffs2 2000000 0 180000
    load_nand_ramdisk=nand read.jffs2 2200000 200000 3000000
    nand_boot=run ramargs addip addtty load_nand_kernel load_nand_ramdisk;bootm 2000
    serverip=192.168.250.3
    ipaddr=192.168.250.108
    gateway=192.168.250.1
    netmask=255.255.255.0
    bootargs=root=/dev/nfs rw nfsroot=192.168.250.3:/usr/src/PADS_1.0.0.62/build_wa0
    bootcmd=run net_nfs
    gatewayip=192.168.250.1
    roothpath=/usr/src/PADS_1.1.0.62/build_warp/root
    mem=262124k
    ver=U-Boot 1.3.0-61 (Sep 2 2008 - 10:25:42)
    rootpath=/usr/src/PADS_1.1.0.62/build_warp/root
    Environment size: 1296/8187 bytes
    ~~ Protected Environment Variables: ~~
    ethaddr=00:1E:84:00:01:39
    serial#=PIK-258- 00709
    => reset

    Resetting board...Goodbye.

    U-Boot 1.3.0-61 (Sep 2 2008 - 10:25:42)
    CPU: AMCC PowerPC 440EP Rev. C at 533.333 MHz (PLB=133, OPB=66, EBC=66 MHz)
    I2C boot EEPROM enabled
    Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)
    , PCI async ext clock used 32 kB I-Cache 32 kB D-Cache

    Board: PIKA Embedded Appliance
    I2C: ready
    DRAM: 256 MB
    ### Press 'p' to enter POST ###: 0
    FLASH: 4 MB
    NAND: 256 MiB
    In: serial
    Out: serial
    Err: serial
    Protected 4 sectors

    FPGA download...complete.
    FPGA code revision 1.3.3.8
    Net: ppc_4xx_eth0
    .ENET Speed is 100 Mbps - FULL duplex connection (EMAC0)
    Hit any key to stop autoboot: -1
    TFTP from server 192.168.250.3; our IP address is 192.168.250.108
    Filename 'cuImage.warp'.
    Load address: 0x200000
    Loading: T T T T T T T T T T
    Retry count exceeded; starting again
    ## Booting image at 00200000 ...
    Bad Magic Number
    =>
    __________________________________________________ _____________

    -rwxrwxrwx 1 asterisk asterisk 1540096 Oct 17 10:31 cuImage.warp
    __________________________________________________ ______________

    [root@sip1 /usr/src/PADS_1.1.0.62/build_warp/root]# ls -al
    total 160
    drwxr-xr-x 19 root root 4096 Oct 17 10:57 .
    drwxr-xr-x 11 root root 4096 Oct 17 10:58 ..
    drwxr-xr-x 2 root root 4096 Oct 17 10:56 bin
    drwxr-xr-x 3 root root 4096 Apr 6 2008 dev
    drwxr-xr-x 2 root root 4096 Oct 17 10:58 etc
    drwxr-xr-x 2 root root 4096 Apr 6 2008 home
    drwxr-xr-x 3 root root 4096 Apr 6 2008 lib
    lrwxrwxrwx 1 root root 11 Oct 17 10:54 linuxrc -> bin/busybox
    drwxr-xr-x 4 root root 4096 Apr 6 2008 mnt
    drwxr-xr-x 5 root root 4096 Oct 17 10:53 persistent
    drwxr-xr-x 2 root root 4096 Oct 17 10:57 persistent1
    drwxr-xr-x 2 root root 4096 Oct 17 10:57 persistent2
    drwxr-xr-x 2 root root 4096 Apr 6 2008 proc
    drwxr-xr-x 2 root root 4096 Apr 6 2008 root
    drwxr-xr-x 2 root root 4096 Oct 17 10:54 sbin
    drwxr-xr-x 5 root root 4096 Oct 17 10:01 service
    drwxr-xr-x 2 root root 4096 Apr 6 2008 sys
    drwxr-xr-x 2 root root 4096 Apr 6 2008 tmp
    -rw-r--r-- 1 root root 0 Oct 17 09:50 .unpacked
    drwxr-xr-x 7 root root 4096 Apr 6 2008 usr
    drwxr-xr-x 6 root root 4096 Apr 6 2008 var

  6. #6
    Join Date
    Jul 2008
    Posts
    268

    Default

    The error present here is the result of attempting to run NFS however either a) tftp is not setup correctly or b) there is no kernel image (cuImage.warp) in the tftpboot folder.

    If you believe tftp is not setup correctly, ensure that tftp is installed correctly on the development machine and the IP addresses are correct.

    If this looks ok then ensure that the image file cuImage.warp resides in the tftpboot folder. This is typically set by default to '/tftpboot'.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •