Results 1 to 5 of 5

Thread: Problem running Openvpn server error : /dev/net/tun : no such device (errno=19)

  1. #1

    Default Problem running Openvpn server error : /dev/net/tun : no such device (errno=19)

    I have a problem after installing Openvpn on the warp : I don't have tun interface on the warp.
    Does someone know how to install tun interface ?


    My screen after run openvpn server.conf :
    Thu Oct 4 09:30:12 2012 Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
    Thu Oct 4 09:30:12 2012 Note: Attempting fallback to kernel 2.2 TUN/TAP interface
    Thu Oct 4 09:30:12 2012 Cannot allocate TUN/TAP dev dynamically
    Thu Oct 4 09:30:12 2012 Exiting

    Thanks

  2. #2
    Join Date
    Jul 2008
    Posts
    268

    Default

    Yes, it appears that tun is not enabled in the kernel used on Warp today. I would suggest contacting Pika to get this added.

  3. #3

    Default

    Ok i will contact Pika.

    Any way to modify the kernel without the pika team ?

  4. #4
    Join Date
    Jul 2008
    Posts
    268

    Default

    Yes it would be possible to manually compile but a lot of unnecessary effort. This omission looks like a simple oversight so I can't see why there would be any objection adding it.

  5. #5
    Join Date
    Jul 2008
    Posts
    268

    Default

    VTUN support has been added in warpkernel package version 2.6.39.2-7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •