Results 1 to 9 of 9

Thread: FXO Line Not Detecting Busy Tone

  1. #1
    carlostico Guest

    Exclamation FXO Line Not Detecting Busy Tone

    I have a FXO module installed in a Pika V2.0

    Sometimes after a call, even if both parties hangup the call never ends, and the DAHDI channel remains busy until I soft hangup it or restart Asterisk manually

    Sometimes just calling a number and getting a busy tone call doesnt end and reminds busy too.

    How to tell Asterisk to hangup as it hears a busy tone or detects silence in both directions ?

  2. #2
    grillovillegas Guest

    Default

    Quote Originally Posted by carlostico View Post
    I have a FXO module installed in a Pika V2.0

    Sometimes after a call, even if both parties hangup the call never ends, and the DAHDI channel remains busy until I soft hangup it or restart Asterisk manually

    Sometimes just calling a number and getting a busy tone call doesnt end and reminds busy too.

    How to tell Asterisk to hangup as it hears a busy tone or detects silence in both directions ?
    Hello:

    Same problem here, apparently the phone company provides remote disconnect supervision but nothing ,so tried to edit the DAHDI files without success. Any other alternative ? , what files to edit or how to implement this feature, its a must in our systems.

    Greetings.
    Last edited by grillovillegas; 08-19-12 at 11:10 AM.

  3. #3
    Join Date
    Jul 2008
    Posts
    268

    Default

    Try the changes below to allow the FXO ports to use tone detection as a source of disconnect supervision. This changes to loop start signaling and enables fast busy detection.

    In '/etc/dahdi/system.conf':

    # Span 1: FXS/1 "Pika FXS Board 1"
    fxoks=1
    echocanceller=WARP,1

    # Span 2: FXO/2 "Pika FXO Board 2"
    fxsls=2
    echocanceller=WARP,2
    fxsls=3
    echocanceller=WARP,3
    fxsls=4
    echocanceller=WARP,4
    fxsls=5
    echocanceller=WARP,5



    In '/etc/asterisk/dahdi-channels.conf:

    ; Span 1: FXS/1 "Pika FXS Board 1"
    ; Skip channel=1(FXS) -- freepbx option.

    ; Span 2: FXO/2 "Pika FXO Board 2" (MASTER) ;;; line="2 FXO/2/0"
    signalling=fxs_ls
    busydetect=yes
    busycount=6
    ;busypattern=500,500
    callerid=asreceived
    group=0
    context=from-pstn
    channel => 2
    callerid=
    group=
    context=default
    ...
    <repeated for all FXO channels>

    You may also need to uncomment and modify the 'busypattern' field for your specific country to match the fast busy cadence. Default is 500, 500.

  4. #4
    voipnauta Guest

    Default

    Quote Originally Posted by mrecoskie View Post
    Try the changes below to allow the FXO ports to use tone detection as a source of disconnect supervision. This changes to loop start signaling and enables fast busy detection.

    In '/etc/dahdi/system.conf':

    # Span 1: FXS/1 "Pika FXS Board 1"
    fxoks=1
    echocanceller=WARP,1

    # Span 2: FXO/2 "Pika FXO Board 2"
    fxsls=2
    echocanceller=WARP,2
    fxsls=3
    echocanceller=WARP,3
    fxsls=4
    echocanceller=WARP,4
    fxsls=5
    echocanceller=WARP,5



    In '/etc/asterisk/dahdi-channels.conf:

    ; Span 1: FXS/1 "Pika FXS Board 1"
    ; Skip channel=1(FXS) -- freepbx option.

    ; Span 2: FXO/2 "Pika FXO Board 2" (MASTER) ;;; line="2 FXO/2/0"
    signalling=fxs_ls
    busydetect=yes
    busycount=6
    ;busypattern=500,500
    callerid=asreceived
    group=0
    context=from-pstn
    channel => 2
    callerid=
    group=
    context=default
    ...
    <repeated for all FXO channels>

    You may also need to uncomment and modify the 'busypattern' field for your specific country to match the fast busy cadence. Default is 500, 500.
    Hi , tried your suggestions but still not working ...... is there any other setting to change ?

  5. #5
    Join Date
    Jul 2008
    Posts
    268

    Default

    Could you collect a recording of the line? To do this:


    a) At the Linux prompt through SSH enter the command below. This will stall the current SSh session.
    dahdi_monitor 2 -r receive.pcm -t transmit.pcm
    b) Next place a call through the Warp's first FXO port
    c) When done press <Ctrl-c> to exit the monitor application over SSh
    d) Then please retrieve the resulting *.pcm files from the Warp using scp. These files will be located in the same directory that the dahdi_monitor command was executed.

  6. #6
    Join Date
    Jul 2008
    Posts
    268

    Default

    Correction - actually it is better to set the following parameters:


    busydetect=yes
    busycount=6
    ;busypattern=500,500


    in /etc/asterisk/chan_dahdi.conf instead of /etc/asterisk/
    dahdi-channels.conf (which is included by chan_dahdi.conf). This is because dahdi-channels.conf file can be modified by the system.


  7. #7
    carlostico Guest

  8. #8
    Join Date
    Jul 2008
    Posts
    268

    Default

    Try:

    busypattern=200,200

  9. #9
    carlostico Guest

    Default

    Quote Originally Posted by mrecoskie View Post
    Try:

    busypattern=200,200
    Hi Mark i measure that audio a while ago and got the exact busy pattern too 200,200 but not success, for some reason the pika just doesn't distinct that
    Have other pbx running same setup with no problems at all.......

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •