Results 1 to 5 of 5

Thread: Fax Configuration

  1. #1
    pbeaton Guest

    Default Fax Configuration

    I have a warp with the 2.2.7-3 FreePBX images installed.
    I am trying to setup Fax 2 Email on it and have got the email side of it working. As for the fax side, at the moment I have things set up as:

    BRI -> Warp -> Ext 250

    Extension 250 is a Virtual Exten set up in FreePBX to be fax enabled, with my email address.

    When I try to send a fax to the and monitor it in asterisk I get:

    Code:
        -- Executing [897xxx@from-pstn:1] Set("PIKA/digital/1", "__FROM_DID=897xxx") in new stack
        -- Executing [897xxx@from-pstn:2] Gosub("PIKA/digital/1", "app-blacklist-check|s|1") in new stack
        -- Executing [s@app-blacklist-check:1] LookupBlacklist("PIKA/digital/1", "") in new stack
        -- Executing [s@app-blacklist-check:2] GotoIf("PIKA/digital/1", "0?blacklisted") in new stack
        -- Executing [s@app-blacklist-check:3] Set("PIKA/digital/1", "CALLED_BLACKLIST=1") in new stack
        -- Executing [s@app-blacklist-check:4] Return("PIKA/digital/1", "") in new stack
        -- Executing [897xxx@from-pstn:3] ExecIf("PIKA/digital/1", "1 |Set|CALLERID(name)=01224899xxx") in new stack
        -- Executing [897xxx@from-pstn:4] Set("PIKA/digital/1", "__CALLINGPRES_SV=allowed_not_screened") in new stack
        -- Executing [897xxx@from-pstn:5] SetCallerPres("PIKA/digital/1", "allowed_not_screened") in new stack
        -- Executing [897xxx@from-pstn:6] Goto("PIKA/digital/1", "ext-fax|250|1") in new stack
        -- Goto (ext-fax,250,1)
        -- Executing [250@ext-fax:1] NoOp("PIKA/digital/1", "Receiving Fax for: Fax Receive (250)| From: "01224899xxx" <01224899xxx>") in new stack
        -- Executing [250@ext-fax:2] Set("PIKA/digital/1", "FAX_RX_EMAIL=paul@<domain>.co") in new stack
        -- Executing [250@ext-fax:3] Goto("PIKA/digital/1", "s|receivefax") in new stack
        -- Goto (ext-fax,s,5)
        -- Executing [s@ext-fax:5] PIKARxFax("PIKA/digital/1", "/var/spool/asterisk/fax/1311604335.9.tif") in new stack
      == Spawn extension (ext-fax, s, 5) exited non-zero on 'PIKA/digital/1'
        -- Executing [h@ext-fax:1] GotoIf("PIKA/digital/1", "0?failed") in new stack
        -- Executing [h@ext-fax:2] GotoIf("PIKA/digital/1", "0?end") in new stack
        -- Executing [h@ext-fax:3] System("PIKA/digital/1", "/var/lib/asterisk/bin/fax-process.pl --to paul@<domain>.co --from "faxes@<domain>.com" --dest "897xxx" --subject "New fax from 01224899xxx <01224899xxx>" --attachment fax_01224899xxx.pdf --type application/pdf --file /var/spool/asterisk/fax/1311604335.9.tif") in new stack
     Error opening /var/spool/asterisk/fax/1311604335.9.tif: No such file or directory at /var/lib/asterisk/bin/fax-process.pl line 133.
       -- Executing [h@ext-fax:4] Macro("PIKA/digital/1", "hangupcall|") in new stack
        -- Executing [s@macro-hangupcall:1] GotoIf("PIKA/digital/1", "1?skiprg") in new stack
        -- Goto (macro-hangupcall,s,4)
        -- Executing [s@macro-hangupcall:4] GotoIf("PIKA/digital/1", "1?skipblkvm") in new stack
        -- Goto (macro-hangupcall,s,7)
        -- Executing [s@macro-hangupcall:7] GotoIf("PIKA/digital/1", "1?theend") in new stack
        -- Goto (macro-hangupcall,s,9)
        -- Executing [s@macro-hangupcall:9] Hangup("PIKA/digital/1", "") in new stack
      == Spawn extension (macro-hangupcall, s, 9) exited non-zero on 'PIKA/digital/1' in macro 'hangupcall'
      == Spawn extension (ext-fax, h, 4) exited non-zero on 'PIKA/digital/1'
    When I cancel the fax sending, the fax machine reports there was No Answer.

    In FreePBX Country Indications are set to United Kingdom, and the pikacf was run to select GB as the country.

    Is there something I'm missing, or are the settings in the config files I need to change?

    Paul

  2. #2
    pbeaton Guest

    Default Fax Configuration - working

    Went back to have another look at the inbound route settings.

    According to the Detect Faxes popup:
    Code:
    Attempt to detect faxes on this DID.
    No: No attempts are made to auto-determine the call type; all calls sent to destination below. Use this option if this DID is used exclusively for voice OR fax.
    Yes: try to auto determine the type of call; route to the fax destination if call is a fax, otherwise send to regular destination. Use this option if you receive both voice and fax calls on this line
    Obviously since this was a fax only DID, I left that as no. However, out of curiosity I changed it to yes, and suddenly I have options for fax detection.
    So I left Fax detection as Zaptel, Detection Time as 4 and set the Fax Destination as extension 250.
    And now when I test it again, Fax2Email works (despite seeing sh: convert: not found in the asterisk CLI)

  3. #3
    pbeaton Guest

    Default

    Well I spoke too soon. I have now taken this Warp to a customer's site and modified the fax configuration, and mail server settings for their set up.
    After a minor change on their mail server (Exchange 2007 SP1), I was able to sucessfully send test emails with:

    cat /var/log/messages | (echo ; cat - ) | sendmail -f myemail@mydomain.com myemail@mydomain.com (with two local email addresses)

    However, while the Fax2Email seems to work (fax detected, .tif created, fax_process.pl runs), no email is received.
    So I reconfigured everything to use an external SMTP service (on port 587 not 25) and again the test emails send OK via that server, but not with Fax2Email through the Warp.

    At each stage I have altered /persistent1/var/www/html/admin/modules/fax/bin/fax-process.pl so that it has read:
    SMTP-> new("internal.mail.server", Debug => 0)
    SMTP-> new("external.mail.server", Debug => 0)
    SMTP-> new("external.mail.server:587", Debug => 0)

    Any suggestions on what to test now?

  4. #4
    Join Date
    Jul 2008
    Posts
    268

    Default

    Regarding your previous posts in this thread - I think a virtual exten 'should' work but I suspect you would need to ensure that fax detection is enabled on this extension which it appears you have.
    More regularly myself I will simply enable fax detection on the incoming route directly (like you eventually did) as opposed to routing the call.

    In terms of your current issue, have you tried setting up a direct IP address in the SMTP line? I wonder if the domain is not resolving which could be causing your problem?

  5. #5
    pbeaton Guest

    Default

    I'll be honest we gave up (2 hours banging my head was enough ), and turned fax detection off on the inbound route for the fax number's DDI and set it to forward the calls to an FXO line with a real fax machine attached to it.
    It had worked great when the warp was set up in our office to test. I had used the ip address of our server while it was in our office, so had replaced that with the ip address of the customer's server. I had to create a new SMTP receiver on the customer's Exchange 2007 server before the sendmail test worked, and in using the external mail server I had used the dns name of it rather than the IP, but the sendmail test worked. It was just fax-process.pl that had issues.

    I might see if I can get a similar setup in our office and see if it's related to that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •