Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: How do I set the timezone on the WARP?

  1. #1
    rutileblue Guest

    Default How do I set the timezone on the WARP?

    My originating problem is that the time reported for voicemail messages is in UTC time, not in local time. (I would like it reported as USA (Central).) Doing a 'date' command at the WARP command line also reports the time as UTC. There is also no TZ environment variable defined. So I believe the WARP believes it is UTC -- I would like it to report time as Central Time.

    Reading the PADS User Guide, section7.3.1, I do have the "Timezone Info Package" included when building. I've also added this line to my S32ntpd file on the WARP (and rebooted after the change):

    export TZ=CST6CDT

    That, as far as I can tell, has no effect. (ie I still get time reported as UTC at the command line and in Asterisk.)

    So... What am I missing or misunderstanding?

    Thanks for any direction or suggestions!

    PS: I do have my Asterisk voicemail.conf configured to have a timezone for the mailbox, so I don't believe that is the issue.

  2. #2
    rutileblue Guest

    Default Poking around...

    I was poking around a bit more and found some interesting items (at least, they are interesting to me; you all probably knew this... )

    First... In the S32ntpd file, I added the -d flag to see the debug info. This is the output after rebooting:

    31 Dec 18:00:16 ntpdate[104]: ntpdate 4.2.0a@1.1190-r Sat Jan 20 10:34:17 MET 2007 (1)
    Looking for host 0.us.pool.ntp.org and service ntp
    host found : tesla.fireduck.com
    transmit(69.31.13.210)
    receive(69.31.13.210)
    transmit(69.31.13.210)
    receive(69.31.13.210)
    transmit(69.31.13.210)
    receive(69.31.13.210)
    transmit(69.31.13.210)
    receive(69.31.13.210)
    transmit(69.31.13.210)
    server 69.31.13.210, port 123
    stratum 2, precision -20, leap 00, trust 000
    refid [69.31.13.210], delay 0.09442, dispersion 0.00000
    transmitted 4, in filter 4
    reference time: cc88d019.d5fb4969 Sat, Sep 27 2008 10:30:33.835
    originate timestamp: cc88d871.08fa88c9 Sat, Sep 27 2008 11:06:09.035
    transmit timestamp: 83aa7e91.67de5082 Wed, Dec 31 1969 18:00:17.405
    filter delay: 0.09937 0.09943 0.10464 0.09442
    0.00000 0.00000 0.00000 0.00000
    filter offset: 12225315 12225315 12225315 12225315
    0.000000 0.000000 0.000000 0.000000
    delay 0.09442, dispersion 0.00000
    offset 1222531551.594894

    31 Dec 18:00:17 ntpdate[104]: step time server 69.31.13.210 offset 1222531551.594894 sec

    So I see it getting the time for the correct timezone (the green text), but it looks like the Warp believes its time is Dec 31, 1969...

    So... Is there no battery on the clock? Does it really reset to 1969 after every reboot, then depends on ntp to bring it back to this century?

    Second... looking at other linux distro's, they have timezone information in the /usr/share/zoneinfo folder. I'm not seeing that folder on my Warp. It's true that when I ran 'make menuconfig', I had chosen not to include all timezone information, so I imagine that's why... If I had chosen "Full timezone information", would it then create a zoneinfo folder? And, just curious... Where is the source timezone info kept otherwise?

    Third...
    most other distros also have a /etc/localtime; I noticed my Warp did not. I went back to the PADS documentation and saw that one could run the 'timezone' command... Perhaps, I thought, that would do something? It did! It created the localtime entry in the etc directory. And, now, when the unit reboots, it has the correct Central time. Yay!

    Which makes me wonder... Is it a requirement to run 'timezone' on the Warp? The documentation doesn't indicate that is so...

    Lastly...
    Alas, Asterisk voicemail still believes it is UTC. Any ideas on that front? Anybody else have a similar problem with voicemail?
    Last edited by rutileblue; 09-27-08 at 02:33 PM.

  3. #3
    Join Date
    Jun 2008
    Posts
    68

    Default How do I set the timezone on the WARP?

    Hi,

    Based on your feedback we have been able to reproduce the problem.
    We are investigating and will post a solution as soon as we can.

    PIKA Support

  4. #4
    skar Guest

    Default

    To answer your questions, ...

    Yes the WARP resets to 1969 on every reboot and uses ntp to bring it to the correct time.

    Yes it is a requirement to build the full timezone information in PADS and run timezone. Doing export TZ=CST6CDT will not work. The timezone info is created in /persistent/usr/share/zoneinfo

    There is no battery on the WARP. That is an option being examined for the next release of the WARP hardware.

  5. #5
    rutileblue Guest

    Default Any update?

    Time has passed... Can you post an update as to when I can expect a fix?

  6. #6
    skar Guest

    Default

    What fix are you looking for? I have tried to answer a couple of your questions. If I have missed what specifically you are looking for in a fix, please clarify it for me. Thanks.

    If it is for a battery on the WARP, there is no update on when that will happen. It is on the feature list for the next spin of the WARP baseboard but there is no current date assigned to when that will occur.

    If it is on the requirement to run timezone, YES it is a requirement. I personally think the option on whether to include full timezone info in PADS should always be turned on. I am not sure why timezone is even split into two pieces.

  7. #7
    rutileblue Guest

    Default Questions answered, but problem still exists

    Thank you for answering the questions. But the problem still exists -- the timestamp of VoiceMail messages is UTC, while the rest of the Warp is correctly in Chicago time. Sorry, but I thought you all had recreated that problem when the 9/30 post said that Support had recreated the problem...

  8. #8
    skar Guest

    Default What version of PADS are you using?

    We never reproduced an error with wrong timezone for voicemail in asterisk, just error with timezone in general. Which version of PADS and asterisk are you using? When I test this with my FreePBX WARP the VM messages all appear with the correct time as set on the computer, EST for me.

    Please post your PADS version and voicemail.conf file so we can see what may be wrong in your setup.

  9. #9
    rutileblue Guest

    Default PADS version and Voicemail.conf

    The PADS version is 1.0.2.8.

    The voicemail.conf is currently:
    /persistent/etc/asterisk # cat voicemail.conf
    [general]
    maxmessage=180
    maxsilence=10
    silencethreshold=250
    format=wav
    tz=central

    [zonemessages]
    eastern=America/New_York|'vm-received' Q 'digits/at' IMp
    central=America/Chicago|'vm-received' Q 'digits/at' IMp
    central24=America/Chicago|'vm-received' q 'digits/at' H N 'hours'
    military=Zulu|'vm-received' q 'digits/at' H N 'hours' 'phonetic/z_p'
    european=Europe/Copenhagen|'vm-received' a d b 'digits/at' HM

    [local]

    2001 => 1111,Theresa Sterbis,,,tz=central
    2002 => 1111,Alison McLaughlin
    2003 => 1111,Kathy Weircinski
    2004 => 1111,Chuck Sterbis
    2005 => 1111,Laurie Flight
    3001 => 1111,Home Kitchen
    This was after poking and prodding a bit to try to solve this problem. The original was like so (which worked fine on the original PC-based system):

    [root@fedora asterisk]# cat voicemail.conf
    [general]
    maxmessage=180
    maxsilence=10
    silencethreshold=250
    format=wav

    [local]

    2001 => 1111,Theresa Sterbis
    2002 => 1111,Alison McLaughlin
    2003 => 1111,Kathy Weircinski
    2004 => 1111,Chuck Sterbis
    2005 => 1111,Laurie Flight
    3001 => 1111,Home Kitchen

  10. #10
    skar Guest

    Default

    In my working voicemail configuration, I do not specify the

    tz=central

    in the configuration and it just pulls in the system timezone properly. You should try this. I am using version 1.2.0.67 of PADS however.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •