In some instances you may observe that Pika's kernel mode drivers fail to start in Linux. This may also be observed when no boards are detected in PikaSetup. In cases like this the messaging in dmesg on the computer might contain something like the following when the drivers attempts to start.

Aug 7 08:06:12 ptest kernel: PCI: Unable to reserve mem region #1:100@fb402000 for device 0000:02:0d.0
Aug 7 08:06:12 ptest kernel: PikaPrimeNet pci_request_regions failed
Aug 7 08:06:12 ptest kernel: PikaPrimeNet: probe of 0000:02:0d.0 failed with error -16


The resolution is to add pci=nommconf to Linux boot parameters via the GRUB configuration file /boot/grub.conf. This is a workaround against buggy BIOSes passing broken ACPI MMCONF configuration tables to the Linux kernel. By using this parameter, you are instructing the Linux kernel to ignore these and do the work itself. It is a well known kernel boot parameter and has been used with kernel/motherboard combinations showing this kind of behaviour. More details are here:
http://www.linuxtopia.org/online_boo...tion/re95.html

We do not recommend making this change in a working system.