Results 1 to 5 of 5

Thread: Kernel checksum error in update

  1. #1
    cincinatofurtado Guest

    Default Kernel checksum error in update

    Hi everyone,

    I've a PIKA Warp with S/N PIK-229-00421 and model number PIK-99-00910 .
    So, I tried to fully update (including u-boot, kernel, persistents, FPGA...) the appliance via tftp to get new versions and the recent GUI and everything was appears to be ok. So I tried to reset the appliance and got an error when verifying checksum in u-boot: "Verifying checksum ... ERROR: Image data failed checksum verification" . The new files were obtained in file "images_2.2.2.3.tgz" and the old one was the stock one. Then I tried all again with files from "images_2.2.1.1.tgz" and same error. Now I've bricked my Warp because I can't boot the kernel.

    I'm writing here because didn't find any other topic about this problem.

    I appreciate any help. Thank you.

  2. #2
    agauthier Guest

    Default Upgrade procedure

    Did you follow the instructions as per
    section 4.1.1 Upgrade Information

    There should be a log file on the USB stick telling you what may have gone wrong.

  3. #3
    Join Date
    Jul 2008



    It sounds like you performed this upgrade manually through uboot and serial cable - is that correct? If so, I believe the error you are seeing is due to a mismatch between the actual size of the kernel image and the size allocated for the kernel on Warp. For reference -

    As suggested in that post you could resolve the error you are seeing by increasing the size of the kernel specified in uboot unfortunately I believe you will then just run into additional problems afterwards.

    Instead I would strongly recommend the following - update by uboot and serial cable to the latest uboot image, reset the Warp and then update all the remaining image files. This should hopefully get you around the problems you are seeing. Let me know if any of this is unclear.

    In the future I would recommend looking at the 'autorun' mechanism for upgrades. It may save a lot of headaches.


  4. #4
    awayte Guest

    Default Upgrade Recovery Procedure


    I thought that for the benefit of others who might encounter this same issue that I would outline a detailed procedure. So here are the steps you are required to perform for recovery:

    1. Copy all of the new images to your tftp server.

    2. Go to the PIKA FTP server and copy the following uboot image to your tftp server:

    3. Reboot the warp, halt the boot process when prompted with the following (Step up the tftp server environment variables if required):

    Hit any key to stop autoboot: 0


    4. Update the uboot with the following command:

    update uboot u-boot-1.3.0-95.bin

    5. Reboot the warp and again halt the boot process when prompted.

    6. Burn the fpga:

    update fpga fpga3011.wrp -d tftp

    7. Enter the following commands as follows:

    setenv load_nand_kernel nand read.jffs2 0x02000000 0x00000000 0x00200000


    8. Reboot the warp and again halt the boot process when prompted.

    9. Enter the following commands as follows. Select yes when prompted for confirmation. No need to reset after each image is burned. You can reboot at the end (Note: the image file names in this case may differ from the images your are upgrading) :

    update kernel kernel- -d tftp
    update persistent persistent-2.2.2-3.wrp -d tftp
    update persistent1 persistent1-2.2.2-3.wrp -d tftp
    update persistent2 persistent2-2.2.2-3.wrp -d tftp
    update ramdisk ramdisk-2.2.2-3.wrp -d tftp

    10. Reboot the Warp and you should be ready to go!


  5. #5
    cincinatofurtado Guest

    Thumbs up

    Hi guys,

    First, thank you all. Just for clarify I used a tftp server in my PC to update Warp and got the error. I didn't used USB nor SD card.

    As I have some experience on u-boot , I thought the error was about image corruption, but I didn't knew why.

    My first try was the command below, as suggested by user awayte:
    # setenv load_nand_kernel nand read.jffs2 0x02000000 0x00000000 0x00200000

    Then I saved with "saveenv" and re-updated. And it worked! Now I'm able to boot in Linux and will try further updates with the "autorun" mechanisms.

    Again, thank you everyone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts