Results 1 to 6 of 6

Thread: Conference set up with Conferences module on FreePBX hangs up after a few seconds

  1. #1
    Doug Guest

    Default Conference set up with Conferences module on FreePBX hangs up after a few seconds

    I have attempted to add a conference option using the Conferences module in FreePBX. However, when a call is placed to the conference, asterisk hangs up after a few seconds.

    I have found a few references indicating the problem is because the meetme application (which is what the conference module in FreePBX is configuring) requires the Zaptel timer - http://www.voip-info.org/wiki/view/Asterisk+cmd+Meetme. Other references indicate that the Zaptel timer can be simulated using ztdummy http://www.voip-info.org/wiki/view/A...+timer+ztdummy

    1) Can somebody confirm if the Conference module/meetme application is hanging up almost immediately because there is a timer missing? Am I missing something else?
    2) What is the correct way to provide a timer on the PIKA Warp? Is it to use ztdummy, or is there some other special hardware on board for doing this?
    3) If ztdummy can solve the problem, I suggest it may be a good idea to include it in the future releases of the FreePBX build for the WARP.

  2. #2
    skar Guest

    Default NOT timer but missing audio files

    This issue is not caused by any missing timer. It is caused by missing audio files on the WARP. The conference extension tries to play a file but it is not there so hangs up.

    To fix this problem, log onto your WARP and do the following:

    #> cd /var/lib/asterisk/sounds
    #> ln -sf conf-getpin.ulaw enter-conf-pin-number.ulaw
    #> ln -sf conf-getconfno.ulaw enter-conf-call-number.ulaw
    #> chown -R asterisk:asterisk /var/lib/asterisk/sounds/

    This should resolve the problem.

    NOTE: This has already been fixed in the trunk of svn code base but is not part of the latest 2.0.8.3 load that was released. It is in the preview load found at the bottom of this page though.


    skar

  3. #3
    Doug Guest

    Default Thanks

    Yes. That was it. Works perfectly now. Thanks

  4. #4
    mikeSGman Guest

    Default

    As for me that didn't work; alas I did verify the missing links b/c of your guide thanks! (If it helps no to note, I had to go to Digium's site and download the asterisk sounds library. I extracted it, b/c after reading this page (thank you) I found that I was missing conf-getpin.ulaw. Of course, I extracted it to a directory of my choice, and copied it over to /var/lib/asterisk/sounds and did the appropriate links and chown's needed.)

    So, in essence here's my problem: Conference worked great a week ago. I did no updates, and made no changes. (seriously) Last night I decided to try a conference again with a few people, and no go. Announces as needed, and accepts incorrect pins asking for the correct pin. Upon successful pin entry it disconnects, and hangs up.

    Any ideas? Very strange. This happened a few weeks back, did a fresh install, and it went away. But now its back... Kinda like that scary old ex-wife.

  5. #5
    skar Guest

    Default

    Well if you did no updates, it is hard to say. Perhaps you can post part of your asterisk log with high detail showing the error occurring.

  6. #6
    Deepak Kenchamba Guest

    Thumbs up

    1. Login as root
    2. Execute the following commands


    Code:
    cd /usr/src/
    wget http://downloads.asterisk.org/pub/telephony/dahdi-linux-complete/releases/dahdi-linux-complete-2.4.0+2.4.0.tar.gz
    tar -zxvf dahdi-linux-complete-2.4.0+2.4.0.tar.gz
    cd dahdi-linux-complete-2.4.0+2.4.0
    make all


    Note: This might lead to an error stating you don't have the kernel source installed.

    3. Download & setup the kernel sources
    3a. Find out your kernel version

    Code:
    uname -r

    mine was '2.6.18-194.17.4.el5'
    3b. Download kernel rpm & extract it with the following commands. Depending on your kernel version & process make your url might change.

    Code:
    cd /
    wget ftp://ftp.muug.mb.ca/mirror/centos/5.5/updates/i386/RPMS/kernel-devel-2.6.18-194.17.4.el5.i686.rpm
    rpm2cpio kernel-devel-2.6.18-194.17.4.el5.i686.rpm | cpio -idmv

    3c Test if download & setup worked

    Code:
    cd /lib/modules/`uname -r`/source

    This should change directory to the kernel sources (using the symbolic link).
    If this works you are all set to get the conference call to work for you.

    4. Complete the dahdi (Digium/Asterisk Hardware Device Interface) setup that was halted in step 2 (above) - with the following commands.

    Code:
    cd /usr/src/dahdi-linux-complete-2.4.0+2.4.0
    make all
    make install
    make config
    chkconfig dahdi on
    service dahdi start


    5. Now try you conference call - it will most likely work.

    I found the following link useful to setup asterisk 1.6
    http://www.voip-info.org/wiki/view/C...x+installation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •