WARP TECHNICAL BULLETIN - WTB0003

Date: March 4, 2010

Product(s): WARP Appliance

Reason: Warp 2.1 Maintenance Release – Required Upgrade
---------------------------------------------------------------------------------------

Description:

PIKA has released an important maintenance release of software for the Warp (PADS 2.1.x). This new release is NOT backwards compatible with your existing Warp image, and it will be necessary for you to transition your solution to this release as soon as possible.

This release contains essential improvements and fixes to areas including u-boot, kernel, SD card performance, and audio quality.

As a result of these improvements, we highly recommend that you begin the upgrade and testing of your WARP solution with PADS 2.1.x.

Warp units shipped from Pika as of today will contain the updated firmware (u-boot and FPGA) that will only be compatible with versions of PADS which are 2.1.x or greater. This means PADS 2.0.x version of software will not be compatible with new Warp applicances shipped as of today. Those in special circumstances should contact PIKA Support with concerns.

If you have initial questions about this release, please refer to the FAQ below and/or contact PIKA Customer Care at support@pikatech.com.

Download Links:


PIKA Warp PADS 2.1: http://www.pikatechnologies.com/english/View.asp?x=822

FreePBX Warp Package: http://pikawarp.org/?p=570


Frequently Asked Questions:

1. What is required to perform the upgrade to this new PADS version?


To perform this upgrade it will be necessary for WARP developers to allocate some development time to move their application to the new version.

Once this porting effort is complete, to commit PADS 2.1.x software to an existing WARP, a special upgrade package and procedure has been created and is contained in the main download package which is located here: (http://www.pikatechnologies.com/english/View.asp?x=822). The upgrade process requires that an SD card or USB memory stick be present in the Warp.


2. Why is the upgrade necessary?

The reason for this upgrade is primarily due to a potential issue found in the 2.0.x release which affects how information is written to the on-board NAND memory of WARP. PIKA strongly recommends that all your stock and deployed WARP units be updated to your new applications package that includes the new PADS 2.1.x release.

3. Is there a comprehensive list of fixes and features available for this new release?

In addition to various bug fixes, this release includes a new tool (named ‘autoflash’) that you will use to commit software to the WARP, as well as support for BRI overlap dialing.

For more information on the complete list of inclusions in this new release, please refer to PIKA WARP Appliance 2.1 Release Notes contained in the main download package which is located here: (http://www.pikatechnologies.com/english/View.asp?x=822)

4. Why will my old software not work on new PIKA Warps?

The kernel partition has increased in size, making it no longer compatible with previous versions. Additionally, the mechanism of how data is written to the on-board NAND memory of WARP has changed.

5. What software does this upgrade affect?

This upgrade affects all software partitions on WARP and requires all partitions to be replaced. (uboot, fpga, cuImage, Ramdisk, persistent, persistent1 and persistent2)

6. I am a FreePBX user. How will I be affected by this change?

A new version of the FreePBX Warp Package is now available (http://pikawarp.org/?p=570) from which to develop.
The upgrade procedure will still be required.

7. Where and when can I obtain this new software?

All of the new software and documentation is now available on PIKA’s web site. The specific links are listed above for your convenience.

8. Will the current release still be supported?

The current PADS release (2.0.x) will be maintained with fixes to significant general software defects. However, we strongly recommend that all customers move to the new release as soon as possible.

9. Can an upgrade to an installed box be done remotely?

If either an SD card or a USB memory stick is present in the box, remote updating of a WARP unit will be possible.