Results 1 to 1 of 1

Thread: WTB0001 - Compatibility of FXO/FXS modules with recent FPGA Firmware

  1. #1
    Join Date
    Jun 2008
    Posts
    68

    Default WTB0001 - Compatibility of FXO/FXS modules with recent FPGA Firmware

    WARP TECHNICAL BULLETIN - WTB0001




    Date Issued: Monday May 25, 2009

    Document Version: Version 1.1

    Software: Warp Firmware upgrade from 1.x to 2.x

    Product(s): WARP Appliance

    Reason: Compatibility issue between Analog Rev A.01/02 and FPGA Firmware 2.x



    Description:

    There is a backwards compatibility issue regarding Analog FXO/FXS modules (Versions A.01 and A.02) and the FPGA Firmware (Version 2.x or newer)

    The BRI module, introduced with the “Warp 2.0” software release, required FPGA firmware changes. These FPGA changes unfortunately are not backwards compatible with the early versions of the Warp Analog FXO and FXS modules.

    Analog modules purchased before January 12th, 2009, will not work properly in a Warp unit which has a FPGA firmware revision 2.x or newer. The following symptoms may be observed:
    - Phantom calls
    - Audio Quality


    Below is a table illustrating the Warp Firmware and Analog Module compatibility matrix.
    http://outgoingftp.pikatech.com/cust...ix_revised.jpg


    Version Identification

    The following steps will show you how to identify both the Analog Module Version number and the FPGA Firmware revision number.

    Analog Modules:
    The revision number of an Analog module can be found on a label located on the plug-in side on the module. The module must be removed from the Warp unit to see the label.


    Figure: Analog FXO module label

    FPGA Firmware:
    To check the FPGA firmware revision please follow one of these methods

    • SSH to the warp
      • “cat /proc/driver/taco | cut –c10-13

    • Serial Port
      • During the Warp startup sequence, the FPGA firmware version will be displayed on the screen.
    Notes:

    N1: FPGA firmware version 2.x or newer is needed on the Warp to use the BRI module

    N2: There is no need to upgrade a Warp’s FPGA from 1.x to 2.x if the unit will not be used with a BRI module.

    N3: Please contact PIKA Support if you would like to have your Rev A.01 or Rev A.02 Analog modules sent back for Repair/Upgrade: support@pikatech.com



    If you have any questions about this technical bulletin, please contact PIKA Support.
    Email: support@pikatech.com
    Last edited by mrecoskie; 09-21-11 at 09:19 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •