PDA

View Full Version : Iptables on Pika Warp V2



carlostico
02-28-12, 06:35 PM
Installed Iptables from the Freepbx GUI with no problems but I got this message when I tried to configure in Webmin

An error occured when checking your current IPtables configuration :
FATAL: Module ip_tables not found.
iptables v1.4.8: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
This may indicate that your kernel does not support IPtables.

This is a Brand New Out of the Box Pika Warp V2 with NAND installed to SD nothing else.

Thanks in advance.

awayte
02-29-12, 12:33 PM
Did you perform an apt-get upgrade on the unit?

Can you perform the following commands and provide the output for each:

dpkg -l | grep warp
dpkg -l | grep webmin
dpkg -l | grep iptables

Thanks

carlostico
02-29-12, 01:27 PM
Hi

Thanks for your answer, and yes i did an apt-get upgrade on the unite

The commands show this output:

root@openwarp:~# dpkg -l | grep warp
ii warpamprep 1.0.27415-4 Displays channel status to the LCD on the PIKA WARP platform.
ii warpasterisk 1.8.9.0-2 This is Asterisk packaged for the PIKA WARP platform.
ii warpbasefiles 3.0.1-5 Base file for PIKA WARP v2 platform.
ii warpchangsm 1.0.27916-2 This is the GSM channel driver for Asterisk.
ii warpdahdi 2.5.0.2+2.5.0.2-17 This is the DAHDI drivers package for the PIKA WARP platform.
ii warpdspctl 1.0.1-3 This is the DSP Control Utility package for the PIKA WARP platform.
ii warpdsplm 1.0.1-1 This is the licensing utility for the DSP on the PIKA WARP platform.
ii warpfailsafe 1.0.28030-1 This is the software package for the Failsafe kernel image
ii warpfpga 1.0.4001-4 Field Programmable Gate Array (FPGA) file for the PIKA WARP platform.
ii warpiptables 1.0.0-1 This is iptables metapackage for the PIKA WARP platform.
ii warpkernel 2.6.39.2-5 The kernel package for the PIKA WARP platform.
ii warpkernel-mod-iptables 2.6.39.2-5 The kernel iptables modules packages.
ii warpliblcd 1.0.27364-1 PIKA WARP LCD Control Library
ii warpmodalsa 1.0.26268-8 This is the ALSA driver package for the PIKA WARP platform.
ii warpmodbootcount 1.0.26664-5 The bootcount driver for the PIKA WARP platform.
ii warpmodgsm 1.0.26345-9 The GSM driver package for the PIKA WARP platform.
ii warpmodlcd 1.0.27364-3 The LCD driver package for the PIKA WARP platform.
ii warpscripts 1.0.27993-1 Some scripts to help work with the PIKA WARP v2 platform.
ii warpuboot 1.3.2-130-1 uboot boot loader for the PIKA WARP Appliance
ii warputils 2.0.27005-2 This is the utils package for the PIKA WARP platform.

root@openwarp:~# dpkg -l | grep webmin
ii webmin 1.580 web-based administration interface for Unix systems

root@openwarp:~# dpkg -l | grep iptables
ii iptables 1.4.8-3 administration tools for packet filtering and NAT
ii iptables-persistent 0.0.20100801 Simple package to set up iptables on boot
ii warpiptables 1.0.0-1 This is iptables metapackage for the PIKA WARP platform.
ii warpkernel-mod-iptables 2.6.39.2-5 The kernel iptables modules packages.

Thanks for your help in advance

CarlosTico

awayte
02-29-12, 02:09 PM
Hello,

I've installed the same package versions as you've kindly shown and encountered the same issue. There seems to be a problem with the installation of the latest iptables package. Log into the shell as 'root' and try running the following command:

depmod -a

This will update your module databases and should alleviate the problem. Please verify this fixes the issue by entering 'Linux Firewall' through 'Webmin'. Let me know if it is successful.

Thanks.

carlostico
02-29-12, 03:06 PM
Hello,

I've installed the same package versions as you've kindly shown and encountered the same issue. There seems to be a problem with the installation of the latest iptables package. Log into the shell as 'root' and try running the following command:

depmod -a

This will update your module databases and should alleviate the problem. Please verify this fixes the issue by entering 'Linux Firewall' through 'Webmin'. Let me know if it is successful.

Thanks.

Thanks very much this seems to fix the problem.