View Full Version : BRI lines no longer working

10-20-11, 09:34 AM
We have a couple of Pika WARP devices and one that has ISDN BRI
connections is currently unable to make or receive calls.

We've disconnected and reconnected cables to the ISDN wallbox and
rebooted/power-cycled the WARP all to no avail. As far as we can tell
incoming calls are reaching the device as they are showing up in the logs but not getting as far as frepbx/asterisk. If it makes any difference we are located in the UK and the ISDN line is provided by BT.

I've tried everything that I can think of, does anyone have any more suggestions of things to try?

I have attached the most recent contents of /var/log/pika in case anyone has the time to take a look.

10-20-11, 11:33 AM
Did this connection previously worked? I would recommend confirming your 'networkconfig=' setting in pikagp_aoh.cfg. Options are 'pp' and 'ptmp'.

10-20-11, 12:22 PM
Yes it worked previously. Sadly changing pp to ptmp makes no difference.

10-21-11, 03:55 AM
Yes the connection used to work. I've now tried the networkconfig set to both pp and ptmp and that sadly hasn't made any difference.

10-21-11, 11:27 AM
Just to confirm - changing this setting will require an Asterisk restart.
Also have you checked with the provider to see if they have changed anything recently?

10-21-11, 11:41 AM
Yes we have changed it and restarted the whole device just to be sure. As far as we are aware nothing has changed at BT.

10-21-11, 11:48 AM
Actually I seem to remember having an issue solved in the past by setting 'countrycode=europe'. This also requires an Asterisk restart.

10-21-11, 11:53 AM
We've currently got countrycode=uk set rather than europe is that likely to be issue.

BTW Is there any reason why are my replies not visible on the thread?

10-25-11, 02:53 AM
So no more ideas about things to look at or log files to examine?

10-25-11, 09:47 AM
From the logs I can see that all the calls seem to be failing with a disconnect cause of 'Invalid Call reference number', the CR number itself seems to always be coming in as 1. I have never seen this before as this value should be unique but then again I am not that familar with the BT ISDN variant. I believe this behavior should have always failed which implies to me that something must have changed.

10-25-11, 12:43 PM
In desperation I deleted all the ISDN trunks from the FreePBX configuration and restarted. After the restart I recreated the trunks and as if by magic things started working! Given that we changed nothing I'm a little mystified but for now to have things working again is a huge relief.