View Full Version : Support for 'w' in Dial command?

08-29-08, 06:06 PM
It doesn't look like the Pika driver (on the WARP) supports a 'w' in the Dial identifier. For whatever reason, my analog lines need that pause at the start of dialing, otherwise the leading digits get "clipped". The 'w' is supported by the drivers for Digium and Sangoma cards. (ie this dialing sequence works with those cards.)

Am I missing something in regards to the Pika driver? Is there another way around the problem? When can you add support for the 'w'?

Output from the Asterisk console:

-- Executing [18472159816@voicepulse-outgoing:1] Dial("SIP/2002-10330310", "PIKA/fxo/1/w15551239898") in new stack
-- group 0/0 channel 0/0 type=4
-- Called fxo/1/w15551239898
[Jan 6 05:00:32] NOTICE[11104]: cdr.c:434 ast_cdr_free: CDR on channel 'PIKA/fxo/1' not posted
== Everyone is busy/congested at this time (1:0/1/0)
== Auto fallthrough, channel 'SIP/2002-10330310' status is 'CONGESTION'

Thank you!

09-02-08, 10:24 AM
The 'w' in the PIKA Dial application on the WARP is to do a wait for dial tone before dialing the digits.

If you wish to do a pause, you need to use the comma character (',') in your dial string.

09-02-08, 04:49 PM
I had actually tried a comma at the start with the other drivers/cards (Digium and Sangoma) but found they did not like it -- they only dialed correctly with a leading 'w'. (This is a port from a working Asterisk box.) I will try leading comma's with the Pika driver. But...

Your reply is focusing on the "pause" aspect and thus indicated to use a comma instead of a 'w'. But, if it is a case of clipping at the start, the 'w' at the start of the dial string should also work, theoretically. What I'm seeing in practice, and what I'm posting about, is that the Pika driver doesn't seem to like it. Can you confirm that the Asterisk Pika driver supports the 'w'? If so, how do you explain the unexpected behavior when it is used?

09-05-08, 09:08 AM
The "w" is wait for dial tone. As such, call progress detection needs to be enabled in the PIKA driver for this to work. This is turned off by default so you should confirm that call progress is enabled in the pika driver. To enable it, you need to edit the /etc/pika/pikagp.cfg file.

In this file under the phone or trunk groups you will see a line like


This is usual commented out with the ";" character. You need to enable it by removing that character.

Also note, if the "w" character is at the start of the dial string, it means wait for dial tone. However if it is in the middle of a Dial string then it is a pause. In this way you do not need to use the comma for a pause, because as you said it is not supported in non-pika drivers.

09-14-08, 10:32 AM
Modifying the pikagp.cfg as you indicated worked -- the 'w' in the dialstring is now recognized (and succeeds).