PDA

View Full Version : Can fax detection be disabled for outbound calls



eurovoice
12-09-09, 12:37 PM
Hi,

We have got an issue that is preventing a "credit-card payment machine" from working via the fxs extenstion. The problem is that when this machine dials out to the credit-card company to establish a data (i.e. modem) conversation with the remote machine, WARP detects the modem answer tone as a fax machine, redirects the call and disconnects the call from fxs/1.

Here is an extract of the asterisk log

Executing [s@macro-dialout-trunk:25] Set("PIKA/fxs/1", "the_num=08003855201") in new stack
-- Executing [s@macro-dialout-trunk:26] Dial("PIKA/fxs/1", "PIKA/fxo/2/08003855201|300|") in new stack
-- group 0/0 channel 1/1 type=4
-- Called fxo/2/08003855201

>> once the remote end answers, the following happens ...

-- Redirecting PIKA/fxo/2 to fax extension
-- Executing [fax@from-pstn:1] Goto("PIKA/fxo/2", "ext-fax|in_fax|1") in new stack
-- Goto (ext-fax,in_fax,1)
-- Executing [in_fax@ext-fax:1] StopPlayTones("PIKA/fxo/2", "") in new stack
-- Executing [in_fax@ext-fax:2] GotoIf("PIKA/fxo/2", "1?3:analog_fax|1") in new stack
-- Goto (ext-fax,in_fax,3)
-- Executing [in_fax@ext-fax:3] Macro("PIKA/fxo/2", "faxreceive") in new stack
-- Executing [s@macro-faxreceive:1] Set("PIKA/fxo/2", "FAXFILE=/var/spool/asterisk/fax/1260376969.68.tif") in new stack
-- Executing [s@macro-faxreceive:2] Set("PIKA/fxo/2", "EMAILADDR=info@eurovoice.co.uk") in new stack
-- Executing [s@macro-faxreceive:3] PIKARxFax("PIKA/fxo/2", "/var/spool/asterisk/fax/1260376969.68.tif") in new stack
-- AsyncGoto/PIKA/fxo/2<ZOMBIE> answered PIKA/fxs/1
-- Executing [h@macro-dialout-trunk:1] Macro("PIKA/fxs/1", "hangupcall|") in new stack
-- Executing [s@macro-hangupcall:1] GotoIf("PIKA/fxs/1", "1?skiprg") in new stack
-- Goto (macro-hangupcall,s,4)
-- Executing [s@macro-hangupcall:4] GotoIf("PIKA/fxs/1", "1?skipblkvm") in new stack
-- Goto (macro-hangupcall,s,7)
-- Executing [s@macro-hangupcall:7] GotoIf("PIKA/fxs/1", "1?theend") in new stack
-- Goto (macro-hangupcall,s,9)
-- Executing [s@macro-hangupcall:9] Hangup("PIKA/fxs/1", "") in new stack
etc.

So, the question is, how can fax detection be disabled when making outgoing calls, yet still remain active in case we/other customers want to use WARP for receiving incoming fax calls?

Thanks.

skar
12-09-09, 03:26 PM
To do this, edit the /etc/asterisk/pika.conf file. In it under all channel types you will see


faxdetection=yes

This is our default value. Change this to no. If you want incoming fax to still work, then on your Inbound Routes, under Fax Handling, change the Fax Detection Type to Zaptel.

Skar (http://twitter.com/skar_pikawarp)

eurovoice
12-09-09, 04:39 PM
Thanks Shawn,

We'll give that a try... do you mind explaining a bit more about what happens when we specify "change the Fax Detection Type to Zaptel."

I thought Zaptel was something to do with Digium (am I allowed to say that word) cards?

Martin.

skar
12-09-09, 05:44 PM
Well in this case it is referring to the asterisk software that performs media processing such as digit detection, tone detection, etc..... The stuff that you would usually associate with DSPs in the "old" telephony world.

Skar (http://twitter.com/skar_pikawarp)