PDA

View Full Version : How To Install Drivers For Inline low density board



vfadmin
07-08-08, 09:20 AM
I installed the low level api and then the high level api. All on Board DSP Versions. I have the typical windows screen popping up which asks me to locate the driver. I have pointed to every imaginable file from the SDK's and it just wont read the board. Went into Pika Setup and tried to autodetect the boards and that didnt work either.

Any ideas on how this is to be done?

Erik

vfadmin
07-08-08, 09:21 AM
Hi Eric,

PIKA Boards should be auto-detected by Windows Device Manager, but if for any reason a board isn't being detected:

A few questions for you:
(1) Which version of Windows are you running?
(2) Which versions of the PIKA API did you install? The latest versions of the DSP-based API are 1.3 (High Level) and 6.5 (Low Level). From the following website:
http://www.pikatechnologies.com/english/View.asp?x=441 (http://www.pikatechnologies.com/english/View.asp?x=441)
(3) Are there any 3rd party boards in the system?

There are a few things that you can try:

-->Installing the low-level driver before installing the high-level driver is the right way to go. Be sure to restart the computer after installing the low-level driver (before you install the high-level driver).

-->If Windows Device Manager asks you to locate the driver, point to the "C:\Program Files\PIKA\MonteCarlo\inf" directory.

--> Otherwise, try this. It's a little tedious, but tends to be a "catch-all" for board detection problems:
-Shut down the system
-Remove the board
-Restart the system with no boards
-Completely uninstall and re-install the drivers (restarting the system when asked)
-Shut down the system once more
-Replace the board (into a *different* PCI slot on the motherboard, if possible),
-Restart the system.

If you are still unable to detect the boards, then perhaps it is an OS incompatibility issue.

Paul

vfadmin
07-08-08, 09:21 AM
Hi Paul,

I have a similar question that Eric ask you, but in my OS is Linux. I've installed a DSP card (PrimeNet family, E1) on my PC, also I've installed a Montecarlo AOB SDK 6.5(low level) but PikaSetup application dont detect my card. I think that is because my version of kernel not match with any versions in the site, I tried with one of them but nothing, my kernel version is 2.6.18
exist a driver to upper version?? any idea to help me??

Michel

vfadmin
07-08-08, 09:21 AM
Hi Michel,

Yes, the Linux kernel you are using must be an exact match with the kernel that your PIKA Driver is built for.

PIKA's DSP-based drivers are available for a number of Linux distributions and 2.6.9-xx kernels. PIKA may also be in a position to build a custom driver, for a specific distribution and kernel, through our Linux on Demand service.
The latest versions are 6.4 and 6.5, found here:

(6.4)
http://www.pikatechnologies.com/english/View.asp?mp=441&x=681 (http://www.pikatechnologies.com/english/View.asp?mp=441&x=681)

(6.5)
http://www.pikatechnologies.com/english/view.asp?x=760 (http://www.pikatechnologies.com/english/view.asp?x=760)


PIKA's current HMP-based drivers provided are field-compilable, and are compatible with most Distributions and Kernels of Linux.

Don't hesitate to use support@pikatech.com for any technical questions.

Paul

kensantos
01-12-09, 10:37 PM
Anyone having this same issue? My OS is Windows XP. System can detect there is a new hardware however when I start to install getting 'Windows could not load the installer for PikaCTI." Tried to uninstall the software and replace the PIKA card on a different slot. It is still the same issue.

rboileau
01-13-09, 09:20 AM
Hi,

Have you tried the following steps ?

a) Uninstall the PIKA SDK(s)
b) Shut down the PC
c) Remove the PIKA Boards
d) Reboot
e) Install the PIKA SDK(s)
f) Reboot
g) Shutdown
h) Install the PIKA Board(s)
i) Reboot


Rod

eurovoice
01-21-09, 09:49 AM
Just to add to Rod's suggestions ... make sure you are running directly from the PC's terminal when installing new hardware. Attempting an install via Windows Remote Desktop is not usually successful.