PDA

View Full Version : Vanilla linux kernel support



muradt
06-12-09, 06:17 AM
Why does new versions of MonteCarlo SDK not support vanilla kernel?

For example this build "PIKA MonteCarlo 6.4.0.16" were support vanilla 2.6.16.20 kernel.

thanks beforehand,
Murad

rboileau
07-31-09, 02:25 PM
Hi Murad,

Since the Pika DSP board drivers are not Open source, it is a lot of work to build and test for all kernels ( x distributions )

Typically we build the first kernel and the most recent kernel for the distribution when we release an SDK.

PIKA does offer the "Linux on Demand" program where you can request a build of a specific Distribution and Kernel for an SDK.

Rod

muradt
08-04-09, 04:06 AM
Hi Rod,

>> Since the Pika DSP board drivers are not Open source, it is a lot of work to build and test for all kernels ( x distributions )
Exactly! That is why vanilla (not patched) kernel support could be helpful. The problem is for patched kernels (like redhat, suse, etc.) "vermagic" string of module is differ.

Murad