PDA

View Full Version : Installing FreePBX modules that are not present



johnq
03-23-09, 11:53 AM
Didn't have a lot of time, but wanted to look at FreePBX on the Warp appliance, so have used the pre-compiled images located here:
ftp://ftp.pikatech.com/outgoing/pads/extras/freepbx/freepbx-mysql-intl-2.0.2.5.tar.gz (ftp://ftp.pikatech.com/outgoing/pads/extras/freepbx/freepbx-mysql-intl-2.0.2.5.tar.gz)
Now I find that the default installation provided on these images has only a few core modules and that most (IVR, Queuing etc) are not installed. Is it safe to just run the online update and download them from the Internet or do they have to be cross-compiled for the Warp using PADS first? What is the correct process?

skar
03-23-09, 12:33 PM
Yes, it is safe to use the Module Admin functionality of FreePBX to add to or update your FreePBX modules. They do not have to be cross compiled in PADS and will work when you install them.

timlitw
03-28-09, 12:11 AM
Upgrading to Core 2.5.1.6 removes the pika hardware fxs and fxo setup options.

skar
04-08-09, 04:01 PM
That is true, when you update the core module, the PIKA types disappear. There is a warning about this on the page announcing the latest release of FreePBX for the WARP, http://pikawarp.org/?p=238 Read Note 1 at the bottom.

I would currently recommend using the custom types for PIKA channels (read above for details) for the time being. A PIKA module for FreePBX is being worked on but it will be a while before it is released. If you have any features you would like to see in this module, please post your feedback in the following thread: http://forum.pikatechnologies.com/showthread.php?t=120